PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Utiliser (si possible) la session existante d'Excel pour un dialogue OLE Automation
ObjetActif (Exemple)
Exemple : Utiliser (si possible) la session existante d'Excel pour un dialogue OLE Automation
L'exemple suivant permet de piloter Excel par OLE Automation. Si une session d'Excel est déjà active, cette session est utilisée pour le dialogue Automation.
A la fin du pilotage d'Excel, l'objet automation est libéré.
Excel est un objet Automation dynamique
// Si un Excel est déjà lancé, on va le récupérer
Excel = ObjetActif("Excel.Application")
SI Excel = Null ALORS
       // Aucun Excel n'est déjà lancé : on en lance un
        Excel = allouer un objet Automation "Excel.Application"
        SI Excel = Null ALORS
                Erreur("Impossible de lancer Excel")
                RETOUR
        FIN
FIN
SI Excel <> Null ALORS
       // Pilotage d'Excel
        ...
       // On libère l'objet Excel utilisé
        libérer Excel
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire