DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Récupération simple d'un fichier
  • Exemple 2 : Récupération de fichiers avec gestion d'une jauge de progression
NetRécupèreFichier (Exemple)
Exemple 1 : Récupération simple d'un fichier
L'exemple suivant permet de récupérer un fichier du serveur sur le poste client.
ConnectFTP est un entier
ConnectFTP = NetConnecte("148.61.125.245", ServeurFTP, "GUEST", "")
...
NetRécupèreFichier(ConnectFTP, "C:\autoexec.bat", "C:\autoexec.cli")
Exemple 2 : Récupération de fichiers avec gestion d'une jauge de progression
Cet exemple permet de récupérer des fichiers présents sur un serveur FTP en gérant une jauge de progression. La fenêtre a pour nom "MAIN". La jauge de progression est gérée dans cette fenêtre.
// -- Code d'ouverture de la fenêtre
// Demande d'un message disponible à Windows
GLOBAL
WM_MYMESSAGE est un entier
lpString est une chaîne fixe sur 20 = "Jauge_Main"
ConnectFTP est un entier
 
// Connexion
ConnectFTP = NetConnecte("148.61.125.245", ServeurFTP, "GUEST", "")
WM_MYMESSAGE = AppelDLL32("USER32", "RegisterWindowMessageA", &lpString)
 
// Branchement de la procédure Jauge sur ce message
Evénement("MAJJauge", "MAIN", WM_MYMESSAGE)
// -- Code du bouton de récupération de fichier
Sablier(Vrai)
SI NetRécupèreFichier(ConnectFTP, "C:\autoexec.bat", ...
"C:\autoexec.cli", WM_MYMESSAGE, 10) = Faux ALORS
Erreur("Erreur dans le transfert de fichier")
FIN
Sablier(Faux)
// -- Procédure MAJJauge()
PROCÉDURE MAJJauge()
// Affichage de la jauge
// Si tout le fichier est transféré, on réinitialise la jauge
SI _EVE.wParam = _EVE.lParam ALORS
// Transfert terminé
Jauge()
SINON
// Transfert en cours
Jauge(_EVE.wParam, _EVE.lParam, "Transfert en cours")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire