PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Écriture dans une matrice
Écriture dans une matrice
Le code suivant permet d'écrire dans une matrice. L'élément (ligne2, colonne3) reçoit la valeur 7.
L'existence de la matrice est testée avec MatExiste. La matrice est créée avec MatCrée. Le nom de la matrice est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
// Déclaration des variables
ResExiste est un booléen
ResEcrase est un booléen
ResCréation est un booléen
ResEcriture est un booléen

// Teste l'existence de la matrice
ResExiste = MatExiste(SAI_NomMatrice)

// La matrice existe
SI ResExiste = Vrai ALORS
        // Écrasement de la matrice ?
        ResEcrase = OuiNon("Cette matrice existe déjà. Voulez-vous l'écraser ?")
FIN

// La matrice n'existe pas ou la matrice doit être écrasée
SI ResExiste = Faux OU ResEcrase = Vrai ALORS
        // Création de la matrice
        ResCréation = MatCrée(SAI_NomMatrice)
FIN

// Erreur ?
SI ResCréation = Faux ALORS
        Erreur(ErreurInfo(errMessage))
SINON
        // Écriture dans la matrice
       // Rappel : L'élément (ligne2, colonne3) reçoit la valeur 7
        ResEcriture = MatEcrit(SAI_NomMatrice, 7, 2, 3)
        SI ResEcriture = Vrai ALORS
                Info("L'écriture a été effectuée")
        SINON
               // Affichage du message d'erreur
                Erreur(ErreurInfo(errMessage))
        FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire