PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Inversion d'une matrice
MatInverse (Exemple)
Inversion d'une matrice
Le code suivant permet d'inverser une matrice. Le nom de la matrice est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
On considère que la matrice a été préalablement créée. L'existence de la matrice est testée avec MatExiste. Le nombre de colonnes de la matrice doit être égal au nombre de lignes de la matrice. Le déterminant ne doit pas être nul.
// -- Code de clic sur BTN_Inversion
// Déclaration des variables
ResInversion est un booléen
// Teste l'existence de la matrice
SI MatExiste(SAI_NomMatrice) = Vrai ALORS
// Nb. colonnes de la matrice = Nb. lignes de la matrice ?
SI MatNbColonne(SAI_NomMatrice) = MatNbLigne(SAI_NomMatrice) ALORS
  // Déterminant non nul ?
SI MatDéterminant(SAI_NomMatrice) <> 0 ALORS
// Inversion de la matrice
ResInversion = MatInverse(SAI_NomMatrice, "MaMatriceInversion")
// Erreur ?
SI ResInversion = Vrai ALORS
Info("L'inversion a été effectuée")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
SINON
Info("Le déterminant est nul")
FIN
SINON
Info("Le nombre de colonnes n'est pas égal au nombre de lignes")
FIN
SINON
Info("La matrice n'existe pas")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire