PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Multiplication de deux matrices
MatMultiplie (Exemple)
Multiplication de deux matrices
Le code suivant permet de multiplier deux matrices.
On considère que les matrices ont été préalablement créées. L'existence des deux matrices est testée avec MatExiste. Le nombre de colonnes de la 1ère matrice doit être égal au nombre de lignes de la 2ème matrice.
// -- Code de clic sur BTN_Multiplication
// Déclaration des variables
ResMultiplie est un booléen
// Teste l'existence des matrices
SI MatExiste("Matrice1") = Vrai ET MatExiste("Matrice2") = Vrai ALORS
// Nb. colonnes de la 1ère matrice = Nb. lignes de la 2ème matrice ?
SI MatNbColonne("Matrice1") = MatNbLigne("Matrice2") ALORS
// Multiplication des deux matrices
ResMultiplie = MatMultiplie("Matrice1", "Matrice2", "MatriceRésultat")
SI ResMultiplie = Vrai ALORS
Info("La multiplication a été effectuée")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
SINON
  Info("Le nombre de colonnes n'est pas égal au nombre de lignes")
FIN
SINON
  Info("Les matrices n'existent pas")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire