PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Valeur d'un amortissement à taux fixe
FinAmortissementDégressif (Exemple)
Valeur d'un amortissement à taux fixe
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsLinuxCode Utilisateur (MCU)Ajax Le code suivant permet de connaître la valeur d'un amortissement. Le coût d'acquisition et la valeur résiduelle du bien, la durée d'amortissement, la période pour laquelle l'amortissement doit être calculé et le nombre de mois de la première année d'amortissement sont saisis par l'utilisateur dans des champs de saisie (SAI_Coût, SAI_ValRésiduelle, SAI_Durée, SAI_Période, SAI_NbMois).
// -- Code de clic sur BTN_ValAmortissement
// Déclaration de la variable
ResValAmortissement est un réel
// Calcul de la valeur d'amortissement
ResValAmortissement = FinAmortissementDégressif(SAI_Coût, SAI_ValRésiduelle, ...
SAI_Durée, SAI_Période, SAI_NbMois)
SI ResValAmortissement <> 0 ALORS
// Affichage du résultat
Info("La valeur d'amortissement est : " + ResValAmortissement)
SINON
SI ResValAmortissement = 0 ALORS
SI FinErreur() = 0 ALORS
Info("La valeur d'amortissement est nulle")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire