PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Matrice d'amortissement
FinAmortissement (Exemple)
Matrice d'amortissement
Le code suivant permet de retourner une matrice d'amortissement. Le type d'amortissement est sélectionné par l'utilisateur grâce à des sélecteurs (SEL_TypeAmort). Le montant, le taux et la durée de l'emprunt sont saisis par l'utilisateur dans des champs de saisie (SAI_Montant, SAI_Taux, SAI_Durée). La matrice d'amortissement s'affiche dans une table mémoire (TABLE_TableMatrice).
// -- Code de clic sur BTN_Amortissement
// Déclaration des variables
ResAmortissement est un booléen
ResTypeAmort est un entier // Récupère le type d'amortissement
ResAjout est un booléen
Indice est un entier
// Récupération du type d'amortissement
SELON SEL_TypeAmort
        CAS 1 : ResTypeAmort = finInFine
        CAS 2 : ResTypeAmort = finAmortissementConstant
        CAS 3 : ResTypeAmort = finAnnuitéConstante
FIN
// Calcul de l'amortissement
ResAmortissement = FinAmortissement("MatriceAmort", ResTypeAmort, SAI_Montant, SAI_Taux, SAI_Durée)
// Erreur de calcul ?
SI ResAmortissement = Faux ALORS
       // Affichage du message d'erreur
        Erreur(ErreurInfo(errMessage))
SINON
        // Affichage de la matrice dans une table mémoire
        POUR Indice = 1 A MatNbLigne("MatriceAmort") ALORS
                ResAjout = TableAjoute(TABLE_TableMatrice, MatLitLigne("MatriceAmort", Indice))
        FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire