PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Addition d'une valeur à tous les éléments d'une matrice
MatRéelAdditionne (Exemple)
Addition d'une valeur à tous les éléments d'une matrice
Le code suivant permet d'additionner la valeur 5 à tous les éléments d'une matrice. Le nom de la matrice est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
On considère que la matrice a été préalablement créée. L'existence de la matrice est testée avec MatExiste.
// --Code de clic sur BTN_AdditionValeur
// Déclaration des variables
ResRéelAddition est un booléen
// Teste l'existence de la matrice
SI MatExiste(SAI_NomMatrice) = Vrai ALORS
// Additionne la valeur 5 à tous les éléments de la matrice
MatRéelAdditionne(SAI_NomMatrice, 5)
// Erreur ?
SI MatErreur(SAI_NomMatrice) = 0 ALORS
Info("L'addition a été effectuée")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
SINON
Info("La matrice n'existe pas")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire