PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Création d'une matrice
Création d'une matrice
Le code suivant permet de créer une matrice. L'existence de la matrice est testée avec MatExiste avant la création de la matrice. Le nom de la matrice est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
// Déclaration des variables
ResExiste est un booléen
ResEcrase est un booléen
ResCréation est un booléen

// Teste l'existence de la matrice
ResExiste = MatExiste(SAI_NomMatrice)

// La matrice existe
SI ResExiste = Vrai ALORS
        // Écrasement de la matrice ?
        ResEcrase = OuiNon("Cette matrice existe déjà. Voulez-vous l'écraser ?")
FIN

// La matrice n'existe pas ou la matrice existante doit être écrasée
SI ResExiste = Faux OU ResEcrase = Vrai ALORS
        // Création de la matrice
        ResCréation = MatCrée(SAI_NomMatrice)
FIN

// Erreur ?
SI ResCréation = Faux ALORS
       // Affichage du message d'erreur
        Erreur(ErreurInfo(errMessage))
SINON
        Info("La matrice a été créée")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire