PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Remplissage d'une matrice
MatRemplit (Exemple)
Remplissage d'une matrice
Le code suivant permet de remplir une matrice. Cette matrice est remplie de la ligne 1 à 5 et de la colonne 1 à 3 par la valeur 7.
L'existence de la matrice est testée avec MatExiste. La matrice est créée avec MatCrée. Le nom de la matrice est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
// Déclaration des variables
ResExiste est un booléen
ResEcrase est un booléen
ResCréation est un booléen
ResRemplissage est un booléen
// Teste l'existence de la matrice
ResExiste = MatExiste(SAI_NomMatrice)
// La matrice existe
SI ResExiste = Vrai ALORS
// Écrasement de la matrice ?
ResEcrase = OuiNon("Cette matrice existe déjà. Voulez-vous l'écraser ?")
FIN
// La matrice n'existe pas ou doit être écrasée
SI ResExiste = Faux OU ResEcrase = Vrai ALORS
// Création de la matrice
ResCréation = MatCrée(SAI_NomMatrice)
FIN
// Erreur ?
SI ResCréation = Faux ALORS
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
SINON
// Remplissage de la matrice.
// Remplissage de la ligne 1 à 5 et de la colonne 1 à 3 par la valeur 7.
ResRemplissage = MatRemplit(SAI_NomMatrice, 7, 5, 3)
// Erreur ?
SI ResRemplissage = Vrai ALORS
Info("La matrice a été remplie")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire