PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Addition de deux matrices de mêmes dimensions
MatAdditionne (Exemple)
Addition de deux matrices de mêmes dimensions
Le code suivant permet d'additionner deux matrices.
Pour cet exemple, on considère que les matrices ont été préalablement créées. L'existence des deux matrices est testée avec MatExiste. Les deux matrices doivent être de mêmes dimensions (même nombre de colonnes vérifié avec MatNbColonne, même nombre de lignes vérifié avec MatNbLigne).
// --Code de clic sur BTN_Addition
// Déclaration des variables
ResAddition est un booléen
// Teste l'existence des matrices
SI MatExiste("Matrice1") = Vrai ET MatExiste("Matrice2") = Vrai ALORS
        // Même nombre de lignes ?
        SI MatNbLigne("Matrice1") = MatNbLigne("Matrice2") ALORS
                // Même nombre de colonnes ?
                SI MatNbColonne("Matrice1") = MatNbColonne("Matrice2") ALORS
                        // Addition des deux matrices
                        ResAddition = MatAdditionne("Matrice1", "Matrice2", "MatriceRésultat")
                        SI ResAddition = Vrai ALORS
                                Info("L'addition a été effectuée")
                        SINON
                                // Affichage du message d'erreur
                                Erreur(ErreurInfo(errMessage))
                        FIN
                SINON
                        Info("Les matrices n'ont pas le même nombre de colonnes")
                FIN
        SINON
                Info("Les matrices n'ont pas le même nombre de lignes")
        FIN
SINON
        Info("Les matrices n'existent pas")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire