PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Copie d'une matrice
Copie d'une matrice
Le code suivant permet de copier une matrice. Le nom de la matrice de base est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
On considère que la matrice à copier a été préalablement créée. L'existence de la matrice est testée avec MatExiste.
// -- Code de clic sur BTN_Copie
// Déclaration des variables
ResCopie est un booléen
// Teste l'existence de la matrice
SI MatExiste(SAI_NomMatrice) = Vrai ALORS
        // Copie de la matrice
        ResCopie = MatCopie(SAI_NomMatrice, "MaMatriceCopie")
        SI ResCopie = Vrai ALORS
                Info("La matrice a été copiée")
        SINON
                // Affichage du message d'erreur
                Erreur(ErreurInfo(errMessage))
        FIN
SINON
        Info("La matrice n'existe pas")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire