DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Valeur d'un amortissement linéaire
FinAmortissementLinéaire (Exemple)
Valeur d'un amortissement linéaire
WEBDEV - Code ServeurAjax Le code suivant permet de connaître la valeur d'un amortissement. Le coût d'acquisition, la valeur résiduelle du bien et la durée d'amortissement sont saisis par l'utilisateur dans des champs de saisie (SAI_Coût, SAI_ValRésiduelle, SAI_Durée).
// --Code de clic sur BTN_ValAmortissement
// Déclaration de la variable
ResValAmortissement est un réel
// Calcul de la valeur d'amortissement
ResValAmortissement = FinAmortissementLinéaire(SAI_Coût, SAI_ValRésiduelle, SAI_Durée)
SI ResValAmortissement <> 0 ALORS
// Affichage du résultat
Info("La valeur d'amortissement est : " + ResValAmortissement)
SINON
SI ResValAmortissement = 0 ALORS
SI FinErreur() = 0 ALORS
Info("La valeur d'amortissement est nulle")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire