PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Calcul du déterminant d'une matrice
MatDéterminant (Exemple)
Calcul du déterminant d'une matrice
Le code suivant permet de calculer le déterminant d'une matrice. Le nom de la matrice est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
On considère que la matrice a été préalablement créée. L'existence de la matrice est testée avec MatExiste. Le nombre de colonnes de la matrice doit être égal au nombre de lignes de la matrice.
// -- Code de clic sur BTN_Déterminant
// Déclaration des variables
ResDéterminant est un réel
// Teste l'existence de la matrice
SI MatExiste(SAI_NomMatrice) = Vrai ALORS
        // Nb. colonnes de la matrice = Nb. lignes de la matrice ?
        SI MatNbColonne(SAI_NomMatrice) = MatNbLigne(SAI_NomMatrice) ALORS
                // Calcul du déterminant
                ResDéterminant = MatDéterminant(SAI_NomMatrice)
                SI ResDéterminant <> 0 ALORS
                        Info("La valeur du déterminant est : " + ResDéterminant)
                SINON
                        // Erreur ?
                        SI MatErreur(SAI_NomMatrice) = 0 ALORS
                                Info("Le déterminant est nul")
                        SINON
                                // Affichage du message d'erreur
                                Erreur(ErreurInfo(errMessage))
                        FIN
                FIN
        SINON
                Info("Le nombre de colonnes n'est pas égal au nombre de lignes")
        FIN
SINON
        Info("La matrice n'existe pas")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire