PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Multiplication des éléments d'une matrice par une valeur
MatRéelMultiplie (Exemple)
Multiplication des éléments d'une matrice par une valeur
Le code suivant permet de multiplier tous les éléments d'une matrice par la valeur 5. Le nom de la matrice est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
On considère que la matrice a été préalablement créée. L'existence de la matrice est testée avec MatExiste.
// -- Code de clic sur BTN_MultiplieValeur
// Teste l'existence de la matrice
SI MatExiste(SAI_NomMatrice)=Vrai ALORS
// Multiplication des éléments de la matrice par la valeur 5
MatRéelMultiplie(SAI_NomMatrice, 5)
// Erreur ?
SI MatErreur(SAI_NomMatrice) = 0 ALORS
Info("La multiplication a été effectuée")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
SINON
Info("La matrice n'existe pas")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire