PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Calcul de la transposée d'une matrice
MatTranspose (Exemple)
Calcul de la transposée d'une matrice
Le code suivant permet de calculer la transposée d'une matrice. Le nom de la matrice est saisi par l'utilisateur dans un champ de saisie (SAI_NomMatrice).
On considère que la matrice a été préalablement créée. L'existence de la matrice est testée avec MatExiste.
// -- Code de clic sur BTN_Transposée
// Déclaration des variables
ResTranspose est un booléen
// Teste l'existence de la matrice
SI MatExiste(SAI_NomMatrice) = Vrai ALORS
// Calcul de la transposée de la matrice
ResTranspose = MatTranspose(SAI_NomMatrice, "MaMatriceTransposée")
// Erreur ?
SI ResTranspose = Vrai ALORS
Info("Le calcul de la transposée a été effectué")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
SINON
Info("La matrice n'existe pas")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire