PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Récupération des droits des utilisateurs sur un serveur et copie de ces droits
HInfoDroitServeur (Exemple)
Récupération des droits des utilisateurs sur un serveur et copie de ces droits
WINDEVWindowsCode Utilisateur (MCU) L'exemple suivant permet de :
  • connaître les droits par défaut d'un utilisateur
  • connaître les droits effectifs d'un utilisateur
  • copier les droits par défaut d'un utilisateur sur un autre utilisateur
sDroit est une chaîne
// Récupère le droit de création de base de données de
// l'utilisateur Dupont sur le serveur de la connexion CNX
sDroit = HInfoDroitServeur("CNX", "Dupont", hDroitCréationBDD)
SELON sDroit
CAS hAutorisé
...
CAS hInterdit
...
CAS hHérité
...
FIN
FIN
 
// Récupère le droit final de création de base de données
// de l'utilisateur Dupont sur le serveur de la connexion CNX
sDroit = HInfoDroitServeur("CNX", "Dupont", hDroitCréationBDD)
SELON sDroit
CAS hAutorisé
  ...
  CAS hInterdit
  ...
  FIN
FIN
 
// Copie de droits d'un utilisateur à un autre
sDroits1 est une chaîne
sDroits1 = HInfoDroitServeur("CNX", "Dupont", hDroitCréationBDD)
HModifieDroitServeur("CNX", "Durand", hDroitCréationBDD, sDroits1)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire