PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Importer une description de fichier à partir d'un fichier de données existant
  • Exemple : Importation d'un fichier Client/Serveur HFSQL avec mot de passe
  • Exemple : Importer une description de fichier à partir d'un fichier de données existant
  • Exemple : Se connecter au fichier des utilisateurs du Groupware
HDéclareExterne (Exemple)
Exemple : Importer une description de fichier à partir d'un fichier de données existant
WEBDEV - Code ServeurWindowsAjax
L'exemple suivant permet d'utiliser le fichier "C:\UnExemple\CLIENT.FIC" dans l'application en cours. Ce fichier de données est décrit dans l'application "Exemple". Il est importé dans l'application en cours sous le nom "ClientWD". Sa structure est automatiquement importée dans l'analyse du projet en cours. Il est ainsi possible d'ajouter un enregistrement dans ce fichier de données par exemple.
ClientWD est une Source de Données
// Importe la description du fichier CLIENT sous le nom ClientWD
HDéclareExterne("C:\UnExemple\CLIENT.FIC", "ClientWD")
 
// Ajout d'un enregistrement
ClientWD.Nom = "Martin"
...
HAjoute(ClientWD)
 
// Ferme le fichier
HFerme(ClientWD)
 
// On ne veut plus utiliser la description
HAnnuleDéclaration(ClientWD)
Exemple : Importation d'un fichier Client/Serveur HFSQL avec mot de passe
sdMonHotel est une Source de Données
Nouvelle_connexion est une Connexion

HPasse(sdMonHotel, "Tahiti")

// Paramètres de la connexion
Nouvelle_connexion..Provider = hAccèsHFClientServeur
Nouvelle_connexion..Utilisateur = "MonUtilisateur"
Nouvelle_connexion..MotDePasse = "MonMotDePasse"
Nouvelle_connexion..Serveur = "MonIPServeur"
Nouvelle_connexion..BaseDeDonnées = "MaBaseDeDonnees"

// Ouverture de la connexion
SI PAS HOuvreConnexion(Nouvelle_connexion) ALORS
Erreur("Erreur de connexion : ", HErreurInfo())
RETOUR
FIN
SI PAS HDéclareExterne(".\Hotels.fic","sdMonHotel","Nouvelle_connexion") ALORS
Erreur("Erreur sur la déclaration externe : ", HErreurInfo())
RETOUR
FIN

HLitPremier(sdMonHotel)
Info(sdMonHotel.Nom)
Exemple : Importer une description de fichier à partir d'un fichier de données existant
Exemple : Se connecter au fichier des utilisateurs du Groupware
Cet exemple montre comment se connecter au fichier des utilisateurs du Groupware utilisateur lorsque ce fichier est de type HFSQL Client/Serveur.
sdGPWUTIL est une Source de Données
Nouvelle_connexion est une Connexion

// Paramètres de la connexion
Nouvelle_connexion..Provider = hAccèsHFClientServeur
Nouvelle_connexion..Utilisateur = "mon utilisateur"
Nouvelle_connexion..MotDePasse = "mon mot de passe"
Nouvelle_connexion..Serveur = "mon serveur"
Nouvelle_connexion..BaseDeDonnées = "ma base de données"
Nouvelle_connexion..Cryptage = hCryptageNon

// Ouverture de la connexion
SI PAS HOuvreConnexion(Nouvelle_connexion) ALORS
Erreur(HErreurInfo())
RETOUR
FIN

HPasse(sdGPWUTIL,"PCSGPW2001")
SI PAS HDéclareExterne(".\Gpw_GPWU_HFCS\\GPWUTILISATEUR.fic", ...
sdGPWUTIL, Nouvelle_connexion) ALORS
Erreur(HErreurInfo())
RETOUR
FIN

sdGPWUTIL.login = "testman"
SI PAS HAjoute("sdGPWUtil") ALORS Erreur(HErreurInfo())
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire