PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Initialisation et parcours d'une requête SQL
  • Exemple : Connexion à une base de données SQL Serveur puis exécution d'une requête
HExécuteRequêteSQL (Exemple)
Exemple : Initialisation et parcours d'une requête SQL
Windows MobileHFSQLHFSQL Client/ServeurConnecteurs Natifs (Accès Natifs) L'exemple suivant permet d'initialiser une requête pour ensuite la parcourir. Cet exemple utilise le type Source de données pour manipuler la requête.
MaRequête est une Source de Données
// Initialise la requête
SI PAS HExécuteRequêteSQL(MaRequête, ...
"SELECT NOM,PRENOM FROM CLIENT WHERE CLIENT.NOM = 'DUPOND'") ALORS
Erreur("Erreur d'initialisation de la requête" + RC + HErreurInfo())
RETOUR
FIN

// Lecture du premier enregistrement de la requête
HLitPremier(MaRequête)
TANTQUE PAS HEnDehors()
  // Traitement sur l'enregistrement de la requête
  // Accès aux rubriques par MaRequête.<Nom rubrique>
  ...
  // Lecture de l'enregistrement suivant
  HLitSuivant()
FIN
Exemple : Connexion à une base de données SQL Serveur puis exécution d'une requête
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire