PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Initialisation et parcours d'une requête sur des fichiers de données HFSQL
  • Exemple 2 : Initialisation et parcours d'une requête sur un fichier OLE DB
HExécuteRequête (Exemple)
Exemple 1 : Initialisation et parcours d'une requête sur des fichiers de données HFSQL
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileJavaAjaxCode Utilisateur (MCU)HFSQLHFSQL Client/ServeurProcédures stockéesHyper File 5.5 L'exemple suivant permet d'initialiser une requête pour ensuite la parcourir.
// Initialise la requête
SI HExécuteRequête(REQ_MaRequête) = Faux ALORS
Erreur("Erreur d'initialisation de la requête" + RC + HErreurInfo())
RETOUR
FIN
 
// Lecture du premier enregistrement de la requête
HLitPremier(REQ_MaRequête)
TANTQUE PAS HEnDehors()
 // Traitement sur l'enregistrement de la requête
 ...
 // lecture de l'enregistrement suivant
 HLitSuivant()
FIN
HAnnuleDéclaration(REQ_MaRequête)
Exemple 2 : Initialisation et parcours d'une requête sur un fichier OLE DB
WINDEVWEBDEV - Code ServeurEtats et RequêtesAjaxCode Utilisateur (MCU)OLE DB L'exemple suivant permet d'initialiser une requête pour ensuite la parcourir.
// Marequête = "Select * from Clients where IDClient = ?"
// Clients est un fichier OLEDB utilisant la connexion "MaConnexion1"
 
// La requête est exécutée sur "MaConnexion1"
HExécuteRequête(MaRequête, hRequêteDéfaut, 5)
 
// Changement de la connexion utilisée par le fichier "Clients"
HChangeConnexion(Clients, "MaConnexion2")
// La requête est exécutée sur "MaConnexion2"
HExécuteRequête(MaRequête, hRequêteDéfaut, 5)
// Débute une transaction sur "MaConnexion3"
SQLTransaction(sqlDébut, "MaConnexion3")
// Exécute la requête sur "MaConnexion3", quelle
// que soit la connexion utilisée par le fichier "Clients"
HExécuteRequête(MaRequête, "MaConnexion3", hRequêteDéfaut, 5)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire