PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Gestion des erreurs de doublons sur un ajout
HErreurDoublon (Exemple)
Exemple : Gestion des erreurs de doublons sur un ajout
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileJavaAjaxCode Utilisateur (MCU)HFSQLHFSQL Client/ServeurHyper File 5.5OLE DBAccès Natifs Cet exemple permet de gérer les erreurs de doublons lors de l'ajout d'un enregistrement dans le fichier CLIENT. La gestion automatique des erreurs a été préalablement désactivée (fonction HSurErreur).
// Pas de gestion automatique des erreurs (doublons, intégrité, ...)
HSurErreur(CLIENT, "")
SI HAjoute(CLIENT) = Faux ALORS
SI HErreurDoublon() = Vrai ALORS
Erreur("Erreur de doublon sur clé unique", HErreurInfo())
RETOUR
FIN
SI HErreurIntégrité() = Vrai ALORS
Erreur(HErreurInfo())
RETOUR
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire