PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Extraire l'image d'un produit (syntaxe 1)
  • Exemple : Extraire l'image d'un produit (syntaxe 2)
HExtraitMémo (Exemple)
Exemple : Extraire l'image d'un produit (syntaxe 1)
Etats et RequêtesWindowsHFSQLHFSQL Client/ServeurHyper File 5.5OLE DBConnecteurs Natifs (Accès Natifs)
Cet exemple est une procédure permettant d'extraire pour l'enregistrement en cours l'image du produit associé.
PROCEDURE bExtraitProduit(sNomProduit)

SI HLitRecherchePremier(PRODUIT, sNomProduit) = Vrai ALORS
// Photo du produit
SI HExtraitMémo(SQLLitMémo("MaRequete", 2), "Produit.BMP") = Faux ALORS
RENVOYER Faux
FIN
FIN
RENVOYER Vrai
Exemple : Extraire l'image d'un produit (syntaxe 2)
Etats et RequêtesWindowsHFSQLHFSQL Client/ServeurHyper File 5.5OLE DBConnecteurs Natifs (Accès Natifs)
Cet exemple est une procédure permettant d'extraire pour l'enregistrement en cours, le fichier associé à la rubrique mémo PHOTO.
Le fichier est récupéré avec son nom d'origine, dans le répertoire temporaire en cours.
PROCEDURE bExtraitProduit(sNomProduit, sNomFichier est une chaîne)

SI HLitRecherchePremier(PRODUIT, sNomProduit) = Vrai ALORS
// Photo du produit
sInfoMemo est une chaîne
sInfoMemo = HInfoMémo(PRODUIT, PHOTO)
SI sInfoMemo = "" ALORS
RENVOYER Faux // pas de fichier dans le mémo
SINON
// Récupère le nom du fichier original du mémo (sans le chemin)
// avec le répertoire temporaire
sNomFichier est une chaîne
sNomFichier = fRépertoireTemp()+["\"] + ...
fExtraitChemin(ExtraitChaîne(sInfoMemo, 2, TAB), ...
  fFichier + fExtension)

SI HExtraitMémo(PRODUIT, PHOTO, sNomFichier) = Faux ALORS
RENVOYER Faux
FIN

FIN
FIN
RENVOYER Vrai
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire