PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Recherche générique simple
  • Exemple 2 : Recherche sur une clé composée
  • Exemple 3 : Recherche d'un client avec une condition
HLitRecherche (Exemple)
Exemple 1 : Recherche générique simple
Windows MobileHFSQLHFSQL Client/ServeurConnecteurs Natifs (Accès Natifs)
L'exemple suivant effectue une recherche générique sur le nom du client. Si le client est trouvé, la procédure ClientExist est lancée, si aucun client n'est trouvé la procédure ClientInconnu est lancée.
// Recherche générique simple
HLitRecherche(CLIENT, NOMCLI, sNomCli)
SI HTrouve(CLIENT) = Vrai ALORS
ClientExist()
SINON
ClientInconnu()
FIN
Exemple 2 : Recherche sur une clé composée
Windows MobileHFSQLHFSQL Client/ServeurConnecteurs Natifs (Accès Natifs)
L'exemple suivant effectue une recherche sur une clé composée du nom et du prénom. Les clients trouvés sont supprimés.
// Recherche de l'enregistrement
HLitRecherche(CLIENT, NOM_PRENOM, [sNom, sPrénom])

TANTQUE HTrouve(CLIENT) = Vrai
// Suppression
HSupprime(CLIENT)
HLitSuivant(CLIENT,NOM_PRENOM)
FIN
Exemple 3 : Recherche d'un client avec une condition
Windows MobileHFSQLHFSQL Client/ServeurConnecteurs Natifs (Accès Natifs)
Cet exemple permet de rechercher un client avec un chiffre d'affaire supérieur à une valeur donnée.
HLitRecherche(CLIENT, ChiffreAffaires, X)
TANTQUE HEnDehors(CLIENT) = Faux
Ajoute_Client_Liste()
HLitSuivant(CLIENT)
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire