PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Exemple 1 : Modification d'un enregistrement dans un fichier Client
  • Exemple 2 : Modification d'un nouveau fichier de données
Exemple 1 : Modification d'un enregistrement dans un fichier Client
WINDEVJava La fiche client est affichée à l'écran. La fonction EcranVersFichier permet de charger les valeurs saisies en mémoire. L'enregistrement en cours est modifié.
// Modification de l'enregistrement en cours dans un fichier "Client"
EcranVersFichier()
SI HModifie(Client) = Faux ALORS
Erreur("Impossible de modifier le client")
FIN
Exemple 2 : Modification d'un nouveau fichier de données
WINDEVWEBDEV - Code ServeurJavaPHPAjaxHFSQLHFSQL Client/ServeurProcédures stockéesHyper File 5.5OLE DBConnecteurs Natifs (Accès Natifs) Un fichier "Client" est créé. Le code suivant permet de modifier le 5ième enregistrement de ce fichier. Dans ce cas, 4 enregistrements supprimés sont ajoutés en début de fichier.
// Création du fichier "Client"
HCréation(Client)
SI HModifie(Client, 5) = Faux ALORS
Erreur("Impossible de modifier le client")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire