PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Recherche à l'identique d'utilisateurs
  • Exemple 2 : Recherche sur une clé composée
HLitRecherchePremier (Exemple)
Exemple 1 : Recherche à l'identique d'utilisateurs
WINDEVWEBDEV - Code ServeurJavaPHPAjaxHFSQLHFSQL Client/ServeurProcédures stockéesHyper File 5.5OLE DBConnecteurs Natifs (Accès Natifs)
Le fichier "Client" est parcouru selon la clé de parcours "NOM", pour la valeur contenue dans la variable sNom.
HLitRecherchePremier(Client, Nom, sNom)
SI HTrouve(Client) = Vrai ALORS
ClientExistant()
SINON
ClientInconnu()
FIN
Exemple 2 : Recherche sur une clé composée
WINDEVWEBDEV - Code ServeurJavaPHPAjaxHFSQLHFSQL Client/ServeurProcédures stockéesHyper File 5.5OLE DBConnecteurs Natifs (Accès Natifs)
Cet exemple permet de rechercher et de supprimer tous les clients ayant un certain nom et un certain prénom. La recherche se fait sur une clé composée. L'enregistrement est lu.
HLitRecherchePremier(CLIENT, NOM_PRENOM, [sNom, sPrénom])
TANTQUE HTrouve(CLIENT) = Vrai
HSupprime(CLIENT)
HLitSuivant(CLIENT)
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire