DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exécuter une requête HTTP avec des paramètres POST
  • Faire une recherche sur les différents moteurs de recherche
  • Appel d'une requête HTTP
HTTPRequête (Exemple)
Exécuter une requête HTTP avec des paramètres POST
WINDEVCode Utilisateur (MCU)
Le code suivant permet d'exécuter une requête HTTP en passant des paramètres en POST.
sUrlRequete est une chaîne
sUrlRequete = "http://faq.pcsoft.fr/webdev22/faqsearch.awp"
 
// Paramètres Post
sParametrePost est une chaîne
sParametrePost = ChaîneConstruit("search=%1&product=%2", "wdjournal", "WINDEV")
 
// Requête
SI HTTPRequête(sUrlRequete, "", "", sParametrePost) = Vrai ALORS
Info("Requête OK, résultat : ", ...
HTMLVersTexte(HTTPDonneRésultat(httpRésultat)))
SINON
Erreur(ErreurInfo())
FIN
Faire une recherche sur les différents moteurs de recherche
WINDEVCode Utilisateur (MCU)
Le code suivant permet de réaliser une recherche sur différents moteurs de recherche internet.
// URL que l'on veut interroger
sURL est une chaîne
 
// Paramètres à passer (en "get" ici)
sParametres est une chaîne
 
// Résultat de la requête
sRésultat est une chaîne
 
// Valeur à faire rechercher par le moteur
sValeurDeRecherche est une chaîne
 
// Nom de "l'agent" : "Mozilla/4.0...." pour simuler IE
sNomAgent est une chaîne = "Mozilla/4.0 (compatible; MSIE 6.0; Win32)"
sValeurDeRecherche = "PCSOFT WINDEV WEBDEV"
// On remplace les espaces par +
sValeurDeRecherche = Remplace(sValeurDeRecherche, " ", "+")
// OU on remplace les espaces par %20
// cas GOOGLE :
// sURL = "http://www.google.com/search"
// sParametres=ChaîneConstruit("q=%1&start=0", sValeurDeRecherche)
// cas DIR
// sURL = "http://www.dir.com/cgi/recherche"
// sParametres = ChaîneConstruit("req=%1&submit=Nouvelle+recherche", ...
// sValeurDeRecherche) + RC
// cas NOMADE
// sURL = "http://rechercher.nomade.tiscali.fr/recherche.asp"
// sParametres=ChaîneConstruit("MT=%1t&s=%1&opt=0", sValeurDeRecherche)
// cas YAHOO
// sURL = "http://fr.search.yahoo.com/search/fr"
// sParametres=ChaîneConstruit("p=%1&n=10", sValeurDeRecherche)+RC
// Récupération de la page résultat suite à une requête HTTP
// avec les paramètres en ligne de commande
SI HTTPRequête(sURL+"?" + sParametres, sNomAgent) = Faux ALORS
Erreur(ErreurInfo())
SINON
// Pour voir le résultat dans un champ HTML
sRésultat = HTTPDonneRésultat(httpRésultat)
CHPTEXTE = sRésultat
CHPHTML = sRésultat
// Ici on n'affecte pas l'URL au champ HTML,
// mais uniquement le code HTML.
// Le répertoire "en cours" n'est donc pas celui du site
// Les images et scripts ne seront pas trouvées
FIN
Appel d'une requête HTTP
WINDEVCode Utilisateur (MCU)
Le code suivant permet de récupérer une image sur le site "www.windev.com". Cette image sera enregistrée dans le fichier "C:\MesImages\Images.GIF".
// Définition des variables
ResAppel est un booléen
IDFichier est un entier
 
// Ouverture du fichier "C:\MesImages\Images.GIF"
IDFichier = fOuvre("C:\MesImages\Images.GIF", foCréation)
SI IDFichier <> -1 ALORS
// Récupération de l'image
ResAppel = HTTPRequête("http://www.windev.com/img/decor/bloc-h-g.gif")
SI ResAppel = Vrai ALORS
// Enregistrement de l'image récupérée dans le fichier
fEcrit(IDFichier, HTTPDonneRésultat(), ...
Taille(HTTPDonneRésultat())
FIN
// Fermeture du fichier
fFerme(IDFichier)
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire