PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Connexion anonyme
  • Exemple 2 : Connexion passive
  • Exemple 3 : Connexion à un serveur FTP à l'aide d'une fenêtre de connexion
FTPConnecte (Exemple)
Exemple 1 : Connexion anonyme
WEBDEV - Code ServeurWindowsAjax Cet exemple permet d'effectuer une connexion anonyme au serveur FTP spécifié par son adresse IP. Le port utilisé est le port par défaut (21), et le mot de passe envoyé au serveur correspond à l'adresse email par défaut du poste en cours.
nConnexion est un entier
nConnexion = FTPConnecte("192.108.10.2")
Exemple 2 : Connexion passive
WEBDEV - Code ServeurWindowsAjax Cet exemple permet d'effectuer une connexion passive sur le compte FTP "DUPONT" du serveur FTP "ftp.cdrom.com". Cette connexion est réalisée sur le port 2001.
nConnexion est un entier
nConnexion = FTPConnecte("ftp.cdrom.com", "Dupont", "MotDePasse", 2001, Vrai)
Exemple 3 : Connexion à un serveur FTP à l'aide d'une fenêtre de connexion
WEBDEV - Code ServeurWindowsAjax Cet exemple permet à l'utilisateur de se connecter à un serveur FTP grâce à une fenêtre de connexion. Cette fenêtre permet à l'utilisateur de choisir tous les paramètres de la connexion.
Le code ci dessous correspond au code du bouton CONNECTER.
// On ouvre la connexion
SI gbAnonyme = Faux ALORS
        // Connexion nominative
        SI gbAvance = Faux ALORS
                // Paramétrage standard
                gnIDConnexion = FTPConnecte(gsAdresse_FTP, gsNom_Utilisateur, gsMDP_utilisateur)
        SINON
                // Paramétrage avancé
                gnIDConnexion = FTPConnecte(gsAdresse_FTP, gsNom_Utilisateur, ...
                                        gsMDP_utilisateur, gnNuméro_Port, bType, gnDélai)
        FIN
SINON
        // Connexion anonyme
        SI gbAvance = Faux ALORS
                // Paramétrage standard
                gnIDConnexion = FTPConnecte(gsAdresse_FTP)
        SINON
                // Paramétrage avancé
                gnIDConnexion = FTPConnecte(gsAdresse_FTP, "", "", gnNuméro_Port, bType, gnDélai)
        FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire