PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Transfert d'un fichier avec gestion d'une jauge de progression
  • Exemple : Transfert d'un répertoire à la racine d'un compte FTP avec gestion d'une jauge de progression
FTPEnvoie (Exemple)
Exemple : Transfert d'un fichier avec gestion d'une jauge de progression
WINDEVJava
Cet exemple permet d'envoyer un fichier du poste en cours au serveur FTP. La procédure Jauge_Transfert permet de gérer la progression du transfert du fichier dans la fenêtre en cours, affichée sur le poste en cours.
nConnexion est un entier
nConnexion = FTPConnecte("ftp.cdrom.com", "GUEST", "")
 
SI FTPEnvoie(nConnexion, "C:\autoexec.bat", "/autoexec.tmp", "Jauge_Transfert") = Faux ALORS
  Info("Echec du transfert")
FIN
// -- Procédure Jauge_Transfert : gestion du transfert en cours
PROCÉDURE Jauge_Transfert(nTotal, nCourant)
Message("Transfert en cours...")
Jauge(nCourant, nTotal)
// Est-ce que le transfert est fini ?
SI nCourant = nTotal ALORS
Message("Transfert Terminé")
Info("Transfert terminé")
FIN
RENVOYER Vrai
Exemple : Transfert d'un répertoire à la racine d'un compte FTP avec gestion d'une jauge de progression
WINDEVJava
Cet exemple permet d'envoyer un répertoire complet du poste en cours au serveur FTP. La procédure GestionJauge permet de gérer la progression du transfert du fichier dans la fenêtre en cours, affichée sur le poste en cours.
Sablier()
ResEnvoi est un booléen
ResConnecte est un entier = FTPConnecte(sAdresseServeurFTP,"MonCompteFTP","MonMotDePasse",21, Faux)
SI ResConnecte  = -1 ALORS
Sablier(Faux)
Erreur("Erreur de connexion : " + RC + ErreurInfo())
RETOUR
FIN
 
// Connexion réussie : envoi de la galerie
// FTPRepCrée(ResConnecte, "/" + TABLE_Galeries.Nom_de_la_Galerie)
ResEnvoi = FTPEnvoie(ResConnecte, ComplèteRep(RépertoireLocalDesGaleries) + ...
TABLE_Galeries.Nom_de_la_Galerie, ...
"/", "GestionJauge", ftpModeBinaire)
 
SI ResEnvoi = Faux ALORS
Sablier(Faux)
Erreur("Erreur d'envoi de la galerie : " + RC + ErreurInfo())
RETOUR
FIN
 
FTPDéconnecte(ResConnecte)
Jauge()
Sablier(Faux)
Info("Galerie transférée")
// -- Procédure GestionJauge : gestion du transfert en cours
PROCÉDURE GestionJauge(nTaille_totale, nTaille_transférée)
 
Jauge(nTaille_transférée, nTaille_totale, "Transfert de la galerie en cours ...", RougePastel)
RENVOYER Vrai
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire