PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Téléchargement d'un fichier présent sur un poste serveur FTP
  • Téléchargement d'un fichier présent sur un poste serveur FTP
  • Téléchargement d'un fichier présent sur un poste serveur FTP (WINDEV Mobile)
  • Téléchargement d'un fichier présent sur un poste serveur FTP (WINDEV Mobile)
FTPRécupère (Exemple)
Téléchargement d'un fichier présent sur un poste serveur FTP
WINDEVWEBDEV - Code ServeurEtats et RequêtesJavaAjaxCode Utilisateur (MCU) Cet exemple permet de récupérer sur le poste en cours un fichier présent sur le poste serveur FTP. Cet exemple ne gère aucune progression du transfert.
nConnexion est un entier
nConnexion = FTPConnecte("ftp.cdrom.com", "GUEST" , "")
SI nConnexion = -1 ALORS
Erreur ("La connexion au serveur n'a pas pu être établie")
SINON
SI FTPRécupère(nConnexion, "/autoexec.bat", "C:\Temp\") = Vrai ALORS
Info("Transfert terminé")
SINON
Erreur("Echec du transfert")
FIN
FIN
Téléchargement d'un fichier présent sur un poste serveur FTP
WINDEVWEBDEV - Code ServeurEtats et RequêtesJavaAjaxCode Utilisateur (MCU) Cet exemple permet de récupérer sur le poste en cours un fichier présent sur le poste serveur FTP. Cet exemple gère la progression du transfert.
IPServeur est une chaîne
nConnexion est un entier
nConnexion = FTPConnecte(IPServeur, "anonyme", "")
SI nConnexion = - 1 ALORS
Erreur("La connexion au serveur n'a pas pu être établie")
SINON
SI FTPRécupère(nConnexion, "/Info.txt", "C:\Temp\", "TéléchargementFTP") = Vrai ALORS
Info("Transfert terminé")
SINON
Erreur("Echec du transfert")
FIN
FIN
PROCEDURE TéléchargementFTP(tTailleTotale, tTailleTransférée)
Message("Transfert FTP en cours : " + tTailleTransférée + ...
" octets reçus sur " + tTailleTotale + " au total.")
RENVOYER Vrai
Téléchargement d'un fichier présent sur un poste serveur FTP (WINDEV Mobile)
Windows Mobile Cet exemple permet de récupérer sur le poste en cours (Mobile) un fichier présent sur le poste serveur FTP. Cet exemple ne gère aucune progression du transfert.
nConnexion est un entier
nConnexion = FTPConnecte("ftp.cdrom.com", "GUEST", "")
SI nConnexion = -1 ALORS
Erreur("La connexion au serveur n'a pas pu être établie")
SINON
SI FTPRécupère(nConnexion, "/autoexec.bat", "\Temp\") = Vrai ALORS
Info("Transfert terminé")
SINON
Erreur("Echec du transfert")
FIN
FIN
Téléchargement d'un fichier présent sur un poste serveur FTP (WINDEV Mobile)
Windows Mobile Cet exemple permet de récupérer sur le poste en cours (Mobile) un fichier présent sur le poste serveur FTP. Cet exemple gère la progression du transfert.
IPServeur est une chaîne
nConnexion est un entier
nConnexion = FTPConnecte(IPServeur, "anonyme", "")
SI nConnexion = - 1 ALORS
Erreur("La connexion au serveur n'a pas pu être établie")
SINON
SI FTPRécupère(nConnexion, "/Info.txt", "\Temp\", "TéléchargementFTP") = Vrai ALORS
Info("Transfert terminé")
SINON
Erreur("Echec du transfert")
FIN
FIN
PROCEDURE TéléchargementFTP(tTailleTotale, tTailleTransférée)
Message("Transfert FTP en cours : " + tTailleTransférée + ...
" octets reçus sur " + tTailleTotale + " au total.")
RENVOYER Vrai
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire