PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Exemple 1 : Récupération des différentes dates et heures d'un fichier
  • Exemple 2 : Modification de la date de création d'un fichier
fDateHeure (Exemple)
Exemple 1 : Récupération des différentes dates et heures d'un fichier
WINDEVWEBDEV - Code ServeurEtats et RequêtesPHPAjax Le code suivant permet de connaître les différentes dates et heures d'un fichier.
// Déclaration des variables
ResDateHeureCréation est une chaîne
ResDateHeureModification est une chaîne
ResDateHeureAccès est une chaîne
CheminFichier est une chaîne
// Sélection d'un fichier
CheminFichier = "C:\MesRépertoires\Fichier.txt"
// Récupération des différentes dates d'un fichier
ResDateHeureCréation = fDateHeure(CheminFichier, "", fCréation)
ResDateHeureModification = fDateHeure(CheminFichier, "", fModification)
ResDateHeureAccès = fDateHeure(CheminFichier, "", fAccès)
SI ResDateHeureCréation <> "" ET ResDateHeureModification <> "" ET ResDateHeureAccès <> "" ALORS
// Affichage des différentes dates et heures du fichier
Info("La date et l'heure de création est : " + ResDateHeureCréation + RC + ...
"La date et l'heure de modification est : " + ResDateHeureModification + RC + ...
"La date et l'heure d'accès est : "+ ResDateHeureAccès)
SINON
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
Exemple 2 : Modification de la date de création d'un fichier
WINDEVWEBDEV - Code ServeurEtats et RequêtesPHPAjax Le code suivant permet de modifier la date de création d'un fichier par la date système de la machine.
// Déclaration des variables
ResDateHeureCréation est une chaîne
ResDateHeureSystème est une chaîne
CheminHeureFichier est une chaîne
// Sélection d'un fichier
CheminFichier = "C:\MesRépertoires\Fichier.txt"
// Récupération de la date et l'heure système
ResDateHeureSystème = DateSys() + HeureSys()
// Modification de la date de création du fichier sélectionné
ResDateHeureCréation = fDateHeure(CheminFichier, ResDateHeureSystème, fCréation)
SI ResDateHeureCréation <> "" ALORS
// Affichage de la date de création
Info("La date et l'heure de création est à présent : " + ResDateHeureCréation)
SINON
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire