PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Obtenir la taille d'un fichier
  • Obtenir la taille d'un fichier (WEBDEV)
Obtenir la taille d'un fichier
WINDEVEtats et RequêtesWindows MobileJavaCode Utilisateur (MCU) Le code suivant permet d'obtenir la taille d'un fichier. Le nom et le chemin du fichier sont sélectionnés avec la fonction fSélecteur.
// Déclaration des variables
CheminFichier est une chaîne
ResTaille est un entier
// Sélection d'un fichier
CheminFichier = fSélecteur("", "", "Sélectionner un fichier", ...
"Tous fichiers (*.*)" + TAB + "*.*", "", fselOuvre + fselExiste)
// Récupération de la taille du fichier
ResTaille = fTaille(CheminFichier)
// Affichage du message d'erreur si la récupération n'a pas été effectuée
SI ResTaille = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
  // Affichage de la taille du fichier
  Info("Taille du fichier : " + ResTaille + " octets")
FIN
Obtenir la taille d'un fichier (WEBDEV)
WEBDEV - Code ServeurPHPAjax Le code suivant permet d'obtenir la taille d'un fichier.
// Déclaration des variables
CheminFichier est une chaîne
ResTaille est un entier
// Sélection d'un fichier
CheminFichier = "C:\MesRépertoires\Fichier.doc"
// Récupération de la taille du fichier
ResTaille = fTaille(CheminFichier)
// Affichage du message d'erreur si la récupération n'a pas été effectuée
SI ResTaille = -1 ALORS
        Erreur(ErreurInfo(errMessage))
SINON
        // Affichage de la taille du fichier
        Info("Taille du fichier : " + ResTaille + " octets")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire