DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


Lit
  • Exemple : Ouverture d'un fichier sélectionné
  • Exemple : Exécution d'un fichier son sélectionné
  • Manipuler un sélecteur multi-fichiers
fSélecteur (Exemple)
Exemple : Ouverture d'un fichier sélectionné
WINDEVEtats et RequêtesJavaCode Utilisateur (MCU)
Le code suivant permet d'ouvrir un fichier sélectionné. Le sélecteur de fichiers s'ouvre en ouverture de fichier (constante fSelOuvre). Seuls les fichiers existants apparaissent dans le sélecteur de fichiers (constante fSelExiste). Le fichier sélectionné est ouvert en mode lecture/écriture.
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
// Sélection du fichier à ouvrir
NomCheminFichier = fSélecteur("C:\MesRépertoires", "Fichier.txt", ...
"Sélectionner un fichier", "Fichier Texte (*.TXT)" + TAB + ...
"*.txt" + RC + "Tous fichiers (*.*)" + TAB + "*.*", "TXT", fselOuvre + fselExiste)
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = 1 ALORS
  Erreur(ErreurInfo(errMessage))
SINON
  // Traitements dans le fichier ouvert
  ...
  // Fin de traitements
FIN
Exemple : Exécution d'un fichier son sélectionné
WINDEVEtats et RequêtesJavaCode Utilisateur (MCU)
Le code suivant permet de sélectionner un fichier son (de type ".WAV"). Le sélecteur de fichiers s'ouvre en ouverture de fichier (constante fselOuvre). Seuls les fichiers existants apparaissent dans le sélecteur de fichiers (constante fSelExiste). Lors d'un clic sur un fichier présent dans le sélecteur de fichiers, le son est joué.
// --Code de création de la fenêtre
GLOBAL
NomCheminFichier est une chaîne
// --Code de clic sur BTN_SelectFichier
// Code d'initialisation
NumEven est un entier
// Déclaration de l'événement pour jouer le fichier son sélectionné
NumEven = Evénement("JouerSon", FenEnExécution(), 1624)
// Sélection d'un fichier son
NomCheminFichier = fSélecteur("C:\MesRépertoires", "", "Sélectionner un fichier son", ...
"Son wave (*.WAV)" + TAB + "*.wav", "", fselOuvre + fselExiste + fselChange)
// Fin de l'événement
FinEvénement(NumEven)
// Traitements dans le fichier sélectionné
...
// Fin des traitements
// Procédure locale à la fenêtre. Cette procédure permet de jouer le fichier son
PROCÉDURE JouerSon(wMessage, wParam, lParam)
NomFichier est une chaîne fixe sur 261
// Le chemin du fichier ne peut pas dépasser 260 caractères.
 
// Récupération de la chaîne qui contient le nom du fichier en cours de sélection
//Transfert(&NomFichier, lParam, wParam)
NomFichier = ChaîneRécupère(lParam, crAdresseUNICODE)
// NomFichier : chaîne recevant le nom du fichier actuellement sélectionné
// lParam : adresse de la chaîne contenant le nom du fichier en cours de sélection
// wParam : taille de la chaîne contenant le nom du fichier en cours de sélection
 
// Exécution du fichier son sélectionné
Son(NomFichier)
Manipuler un sélecteur multi-fichiers
WINDEV
// Variables
sCheminDocument est une chaîne
sNouveauChemin est une chaîne
sExtension est une chaîne
sTousDocuments est une chaîne
nCpt est un entier
 
// Initialisation des variables
sTousDocuments = fSélecteur("C:\", "Tous les fichiers", ...
"Sélectionnez le document à sauvegarder", "*.*", "*.*", fselOuvre + fselMulti)
 
nCpt = 1
 
// Parcours de chaque document
sCheminDocument = ExtraitChaîne(sTousDocuments, nCpt, RC)
Sablier()
TANTQUE sCheminDocument <> EOT
// Traitement particulier si ce fichier est une image
sExtension = Majuscule(fExtraitChemin(sCheminDocument, fExtension))
SI sExtension = ".GIF" OU sExtension = ".BMP" OU ...
sExtension = ".JPG" OU sExtension = ".JPEG" ALORS
// Appel du composant d'annotation d'images
Ouvre(FEN_ZoomImage, sCheminDocument, 80)
FIN
SI HAttacheMémo(DOC_Contact, Document ,sCheminDocument, hMémoBin) = Faux ALORS
Erreur(HErreurInfo())
SINON
// Affectation des valeurs
DOC_Contact.IDContact = ID_Du_Contact
DOC_Contact.Libelle = fExtraitChemin(sCheminDocument, fFichier)
DOC_Contact.Format = Milieu(fExtraitChemin(sCheminDocument, fExtension), 2, 3)
DOC_Contact.Date = DateSys()
DOC_Contact.Commentaires = Ouvre(FEN_Saisie_Commentaires, sCheminDocument)
// Ajout du dossier
SI HAjoute(DOC_Contact) = Faux ALORS Erreur(HErreurInfo())
FIN
// Traitement du document suivant
nCpt ++
sCheminDocument = ExtraitChaîne(sTousDocuments, nCpt, RC)
FIN
Sablier(Faux)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire