PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Suppression d'un répertoire
  • Suppression d'un répertoire (WEBDEV)
fRepSupprime (Exemple)
Suppression d'un répertoire
WINDEVEtats et RequêtesWindowsJavaCode Utilisateur (MCU)Procédures stockées
Le code suivant permet de supprimer un répertoire. Le répertoire à supprimer est sélectionné par l'utilisateur grâce à la fonction fRepSélecteur.
// -- Code de clic sur BTN_SuppressionRépertoire
// Déclaration des variables
ResSuppression est un booléen
NomCheminRépertoire est une chaîne
// Sélection du répertoire
NomCheminRépertoire = fRepSélecteur("", "Sélectionnez un répertoire", ...
"Sélectionnez le répertoire à supprimer")
// Suppression du répertoire sélectionné
ResSuppression = fRepSupprime(NomCheminRépertoire, frRécursif)
// Erreur ?
SI ResSuppression = Vrai ALORS
Info("Le répertoire a été supprimé")
SINON
  // Affichage du message d'erreur
  Erreur(ErreurInfo(errMessage))
FIN
Suppression d'un répertoire (WEBDEV)
WEBDEV - Code ServeurPHPAjax
Le code suivant permet de supprimer un répertoire.
// -- Code de clic sur BTN_SuppressionRépertoire
// Déclaration des variables
ResSuppression est un booléen
NomCheminRépertoire est une chaîne
// Sélection du répertoire
NomCheminRépertoire = "C:\MesRépertoires\RepASupprimer"
// Suppression du répertoire sélectionné
ResSuppression = fRepSupprime(NomCheminRépertoire, frRécursif)
// Erreur ?
SI ResSuppression = Vrai ALORS
Info("Le répertoire a été supprimé")
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire