PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Lecture d'un bloc d'octets dans un fichier externe
  • Exemple : Lecture d'une chaîne de caractères de longueur fixe
  • Exemple : Transfert des données contenues dans un fichier texte vers une portion de mémoire
  • Exemple : Lecture d'un bloc d'octets dans un fichier externe (WINDEV Mobile)
  • Exemple : Transfert des données contenues dans un fichier texte vers une portion de mémoire (WINDEV Mobile)
Exemple : Lecture d'un bloc d'octets dans un fichier externe
WEBDEV - Code ServeurPHPAjax Le code suivant permet de lire un bloc d'octets dans un fichier externe. Le fichier texte est ouvert en mode lecture/écriture.
Nous considérons que le fichier texte contient : "La programmation facile et rapide !". La lecture des 23 premiers caractères correspond à : "La programmation facile".
// Déclaration des variables
IDFichier est un entier
ResLecture est une chaîne
ResFermeFichier est un entier
// Ouverture du fichier
IDFichier = fOuvre("C:\MesRépertoires\Slogan.TXT", foLectureEcriture)
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Lecture des 23 premiers octets (caractères) dans le fichier
ResLecture = fLit(IDFichier, 23)
// Affichage du message d'erreur si la lecture n'a pas été effectuée
SI ResLecture = "" ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Affichage du bloc d'octets lu
Info(ResLecture) // Affiche "La programmation facile"
FIN
// Fermeture du fichier
ResFermeFichier = fFerme(IDFichier)
SI ResFermeFichier = -1 ALORS
// Affichage du message d'erreur si la fermeture n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
FIN
Exemple : Lecture d'une chaîne de caractères de longueur fixe
WEBDEV - Code ServeurAjax Le code suivant permet d'afficher le contenu d'un fichier texte dans un champ de saisie (SaisieFichier). Chaque lecture correspond à une chaîne de caractères de longueur fixe (50 octets). Le fichier texte est ouvert en mode lecture/écriture. Le contenu du fichier texte est affecté dans une portion de mémoire (identifiée par son adresse) avant d'être affiché dans le champ de saisie.
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
ResLecture est un entier
DonnéeALire est une chaîne ASCII sur 50
ResFermeFichier est un entier

// Sélection du nom et du chemin du fichier
NomCheminFichier = "C:\MesRépertoires\Fichier.txt"
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Lecture des premiers 50 octets dans le fichier
ResLecture = fLit(IDFichier, 50, &DonnéeALire)
// Affichage des premiers octets lus dans le champ de saisie
SAI_SaisieFichier = DonnéeALire
// Autres données à lire ? Erreur de lecture ?
TANTQUE ResLecture <> 0
// Lecture des données suivantes du fichier
ResLecture = fLit(IDFichier, 50, &DonnéeALire)
// Affichage des données suivantes dans le champ de saisie
SAI_SaisieFichier = SAI_SaisieFichier + DonnéeALire
FIN
// Affichage du message d'erreur si la lecture n'a pas été effectuée
SI ResLecture = 0 ALORS Erreur(ErreurInfo(errMessage))
// Fermeture du fichier
ResFermeFichier = fFerme(IDFichier)
SI ResFermeFichier = -1 ALORS
// Affichage du message d'erreur si la fermeture n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
FIN
Exemple : Transfert des données contenues dans un fichier texte vers une portion de mémoire
Exemple : Lecture d'un bloc d'octets dans un fichier externe (WINDEV Mobile)
Exemple : Transfert des données contenues dans un fichier texte vers une portion de mémoire (WINDEV Mobile)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire