PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Récupération des différentes heures d'un fichier
  • Exemple : Modification de l'heure de création d'un fichier
  • Exemple : Récupération des différentes heures d'un fichier (WEBDEV)
  • Exemple : Modification de l'heure de modification d'un fichier (WEBDEV)
Exemple : Récupération des différentes heures d'un fichier
Exemple : Modification de l'heure de création d'un fichier
Exemple : Récupération des différentes heures d'un fichier (WEBDEV)
WEBDEV - Code ServeurPHPAjax Le code suivant permet de connaître l'heure de modification et d'accès d'un fichier.
// Déclaration des variables
ResHeureModification est une chaîne
ResHeureAccès est une chaîne
CheminFichier est une chaîne

// Sélection d'un fichier
CheminFichier = "C:\MesRépertoires\Fichier.txt"
// Récupération des différentes heures d'un fichier
ResHeureModification = fHeure(CheminFichier, "", fModification)
ResHeureAccès = fHeure(CheminFichier, "", fAccès)
SI ResHeureModification <> "" ET ResHeureAccès <> "" ALORS
// Affichage des différentes heures du fichier
Info("L'heure de modification est : " + ResHeureModification + RC + ...
"L'heure d'accès est : " + ResHeureAccès)
SINON
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
Exemple : Modification de l'heure de modification d'un fichier (WEBDEV)
WEBDEV - Code ServeurPHPAjax Le code suivant permet de remplacer l'heure de modification d'un fichier par l'heure système du poste en cours.
// Déclaration des variables
ResHeureModification est une chaîne
ResHeureSystème est une chaîne
CheminFichier est une chaîne

// Sélection d'un fichier
CheminFichier = "C:\MesRépertoires\Fichier.txt"

// Récupération de l'heure système sous forme HHMMSSCC
ResHeureSystème = HeureSys()

// Extraction de l'heure système sous forme HHMMSS
ResHeureSystème = Gauche(ResHeureSystème, 6)

// Modification de l'heure de modification du fichier sélectionné
ResHeureModification = fHeure(CheminFichier, ResHeureSystème, fModification)
SI ResDateModification <> "" ALORS
       // Affichage de l'heure de modification du fichier
        Info("L'heure de modification est à présent : " + ResHeureModification)
SINON
       // Affichage du message d'erreur si la récupération n'a pas été effectuée
        Erreur(ErreurInfo(errMessage))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire