PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Copie d'un répertoire et de ses sous répertoires
  • Copie du répertoire sélectionné par l'utilisateur
fRepCopie (Exemple)
Copie d'un répertoire et de ses sous répertoires
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)Ajax Le code suivant permet de copier un répertoire. Les sous-répertoires sont également copiés (constante frRécursif).
// Déclaration des variables
RépertoireACopier est une chaîne
RépertoireCopié est une chaîne
ResCopie est un booléen
// Sélection du répertoire à copier
RépertoireACopier = "C:\RépertoireA"
// Sélection du répertoire copié
RépertoireCopié = "C:\RépertoireB"
// Copie du répertoire
ResCopie = fRepCopie(RépertoireACopier, RépertoireCopié, frRécursif)
// Affichage du message d'erreur si la copie n'a pas été effectuée
SI ResCopie = Faux ALORS
Erreur(ErreurInfo(errMessage))
SINON
Info("Le(s) répertoire(s) ont été copiés")
FIN
Copie du répertoire sélectionné par l'utilisateur
WINDEVEtats et RequêtesCode Utilisateur (MCU) Le code suivant permet de copier un répertoire. Le répertoire à copier et le répertoire copié sont sélectionnés avec la fonction fRepSélecteur. Une fenêtre de progression s'affiche (constante frJauge).
// Déclaration des variables
RépertoireACopier est une chaîne
RépertoireCopié est une chaîne
ResCopie est un booléen
// Sélection du répertoire à copier
RépertoireACopier = fRepSélecteur("", "Sélection du répertoire à copier")
// Sélection du répertoire copié
RépertoireCopié = fRepSélecteur("", "Sélection du répertoire copié")
// Copie du répertoire
ResCopie = fRepCopie(RépertoireACopier, RépertoireCopié, frJauge)
// Affichage du message d'erreur si la copie n'a pas été effectuée
SI ResCopie = Faux ALORS
Erreur(ErreurInfo(errMessage))
SINON
Info("Le répertoire a été copié")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire