PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Modifier le nom d'un fichier
  • Modifier le nom d'un fichier (WEBDEV)
Modifier le nom d'un fichier
WINDEVEtats et RequêtesJavaCode Utilisateur (MCU) Le code suivant permet de modifier le nom d'un fichier. Le fichier à renommer et le fichier renommé sont sélectionnés avec la fonction fSélecteur.
// Déclaration des variables
FichierARenommer est une chaîne
FichierRenommé est une chaîne
ResModifNom est un booléen
// Sélection du fichier à renommer
FichierARenommer = fSélecteur("", "", "Sélection du fichier à renommer", ...
"Tous fichiers (*.*)" + TAB + "*.*" , "", fselOuvre + fselExiste)
// Sélection du fichier renommé
FichierRenommé = fSélecteur("", "", "Sélection du fichier renommé", ...
"Tous fichiers (*.*)" + TAB + "*.*", "", fselCrée)
// Modification du nom du fichier
ResModifNom = fRenomme(FichierARenommer, FichierRenommé)
// Affichage du message d'erreur si la modification n'a pas été effectuée
SI ResModifNom = Faux ALORS
Erreur(ErreurInfo(errMessage))
SINON
Info("Le fichier a été renommé")
FIN
Modifier le nom d'un fichier (WEBDEV)
WEBDEV - Code ServeurPHPAjax Le code suivant permet de modifier le nom d'un fichier.
// Déclaration des variables
FichierARenommer est une chaîne
FichierRenommé est une chaîne
ResModifNom est un booléen
// Sélection du fichier à renommer
FichierARenommer = "C:\MesRépertoires\Fichier.txt"
// Sélection du fichier renommé
FichierRenommé = "C:\MesRépertoires\FichierRenommé.txt"
// Modification du nom du fichier
ResModifNom = fRenomme(FichierARenommer, FichierRenommé)
// Affichage du message d'erreur si la modification n'a pas été effectuée
SI ResModifNom = Faux ALORS
Erreur(ErreurInfo(errMessage))
SINON
Info("Le fichier a été renommé")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire