PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Exemple : Ouverture d'un fichier externe
  • Exemple : Ouverture et/ou création d'un fichier externe
  • Exemple : Ouverture d'un fichier externe (WEBDEV)
  • Exemple : Ouverture et/ou création d'un fichier externe (WEBDEV)
Exemple : Ouverture d'un fichier externe
WINDEVEtats et RequêtesWindows MobileJavaCode Utilisateur (MCU)
Le code suivant permet d'ouvrir un fichier externe. Le fichier est ouvert en mode lecture/écriture. Le nom et le chemin du fichier sont sélectionnés avec la fonction fSélecteur.
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
// Sélection du nom et du chemin du fichier
NomCheminFichier = fSélecteur("", "", "Sélection d'un fichier externe", ...
"Fichier externe" + TAB + "*.txt", "txt", fselCrée)
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
  Erreur(ErreurInfo(errMessage))
SINON
  // Traitements dans le fichier ouvert
  ...
  // Fin de traitements
FIN
Exemple : Ouverture et/ou création d'un fichier externe
WINDEVEtats et RequêtesWindows MobileJavaCode Utilisateur (MCU)
Le code suivant permet d'ouvrir et/ou de créer un fichier externe. Le fichier est ouvert en mode lecture/écriture. Le nom et le chemin du fichier sont sélectionnés avec la fonction fSélecteur. Si le fichier existe déjà, ce fichier ne sera pas recréé (constante foCréationSiInexistant).
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
// Sélection du nom et du chemin du fichier
NomCheminFichier = fSélecteur("", "", "Sélection d'un fichier externe", ...
"Fichier externe" + TAB + "*.txt", "txt", fselCrée)
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture + foCréationSiInexistant)
// Affichage du message d'erreur si la création n'a pas été effectuée
SI IDFichier = -1 ALORS
  Erreur(ErreurInfo(errMessage))
SINON
  // Traitements dans le fichier ouvert
  ...
  // Fin de traitements
FIN
Exemple : Ouverture d'un fichier externe (WEBDEV)
WEBDEV - Code ServeurPHPAjax
Le code suivant permet d'ouvrir un fichier externe. Le fichier est ouvert en mode lecture/écriture.
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
// Sélection du nom et du chemin du fichier
NomCheminFichier = "C:\MesRépertoires\Fichier.txt"
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Traitements dans le fichier ouvert
...
// Fin de traitements
FIN
Exemple : Ouverture et/ou création d'un fichier externe (WEBDEV)
WEBDEV - Code ServeurPHPAjax
Le code suivant permet d'ouvrir et/ou de créer un fichier externe. Le fichier est ouvert en mode lecture/écriture. Si le fichier existe déjà, ce fichier ne sera pas recréé (constante foCréationSiInexistant).
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
// Sélection du nom et du chemin du fichier
NomCheminFichier = "C:\MesRépertoires\Fichier.txt"
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture + foCréationSiInexistant)
// Affichage du message d'erreur si la création n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Traitements dans le fichier ouvert
...
// Fin de traitements
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire