PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Afficher dans un champ Liste les noms longs des fichiers présents dans un répertoire
Afficher dans un champ Liste les noms longs des fichiers présents dans un répertoire
WINDEVEtats et RequêtesCode Utilisateur (MCU) Le code suivant permet de :
  • stocker les noms des fichiers d'un répertoire dans un tableau (TableauChemin),
  • afficher les noms longs de l'ensemble des fichiers d'un répertoire dans un champ Liste (LISTE_ListeNomLong).
// Déclaration et initialisation des variables
CheminFichierRep est une chaîne
ResNomLong est une chaîne
IndiceTab est un entier = 0 // Indice du tableau
IndiceBoucle est un entier
TableauChemin est un tableau
 
// Récupération du premier fichier d'un répertoire
CheminFichierRep = fRep("C:\MesRépertoires\*.*", frFichier)
TANTQUE CheminFichierRep <> "" ALORS
// Incrémentation de l'indice du tableau
IndiceTab++
// Intégration des noms des fichiers dans le tableau
TableauChemin[IndiceTab] = CheminFichierRep
// Récupération du fichier suivant
CheminFichierRep = fRep("")
FIN
POUR IndiceBoucle = 1 À IndiceTab
// Récupération du nom long
ResNomLong = fNomLong(TableauChemin[IndiceBoucle])
SI ResNomLong = "" ALORS
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
SINON
// Affichage du nom long dans le champ Liste
ListeAjoute(LISTE_ListeNomLong, ResNomLong)
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire