PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Afficher dans un champ Liste les noms courts des fichiers présents dans un répertoire
fNomCourt (Exemple)
Afficher dans un champ Liste les noms courts des fichiers présents dans un répertoire
Le code suivant permet de :
  • stocker les noms des fichiers d'un répertoire dans un tableau (TableauChemin),
  • afficher les noms courts de l'ensemble des fichiers d'un répertoire dans un champ Liste (LISTE_ListeNomCourt).
// Déclaration et initialisation des variables
CheminFichierRep est une chaîne
ResNomCourt est une chaîne
IndiceTab est un entier = 0 // Indice du tableau
IndiceBoucle est un entier
TableauChemin est un tableau
 
// Récupération du premier fichier d'un répertoire
CheminFichierRep = fRep("C:\MesRépertoires\*.*", frFichier)
TANTQUE CheminFichierRep <> "" ALORS
// Incrémentation de l'indice du tableau
IndiceTab++
// Intégration des noms des fichiers dans le tableau
TableauChemin[IndiceTab] = CheminFichierRep
// Récupération du fichier suivant
CheminFichierRep = fRep("")
FIN
 
POUR IndiceBoucle = 1 À IndiceTab
// Récupération du nom court
ResNomCourt = fNomCourt(TableauChemin[IndiceBoucle])
SI ResNomCourt = "" ALORS
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
SINON
// Affichage du nom court dans le champ Liste
ListeAjoute(LISTE_ListeNomCourt, ResNomCourt)
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire