PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Lecture d'une ligne dans un fichier externe
  • Lecture d'une ligne dans un fichier externe (WINDEV Mobile)
fLitLigne (Exemple)
Lecture d'une ligne dans un fichier externe
WINDEVWEBDEV - Code ServeurEtats et RequêtesJavaPHPAjaxCode Utilisateur (MCU) Le code suivant permet d'afficher le contenu d'un fichier texte dans un champ de saisie (SAI_SaisieFichier). Chaque lecture correspond à une ligne du fichier texte.
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
LigneLue est une chaîne

// Sélection du nom et du chemin du fichier
NomCheminFichier ="C:\MesRépertoires\Fichier.txt"
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier)
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
BOUCLE
// Lecture de la première ligne du fichier
LigneLue = fLitLigne(IDFichier)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
SORTIR
FIN
// Fin de fichier ?
SI LigneLue = EOT ALORS SORTIR
// Traitement de la ligne lue
// Ici ajout à la fin d'un champ de saisie
SAI_ContenuFichier += [RC] + LigneLue
FIN
// Fermeture du fichier
fFerme(IDFichier)
ToastAffiche("Lecture du fichier terminée")
FIN
Lecture d'une ligne dans un fichier externe (WINDEV Mobile)
Windows Mobile Le code suivant permet d'afficher le contenu d'un fichier texte dans un champ de saisie (SAI_SaisieFichier). Chaque lecture correspond à une ligne du fichier texte.
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
LigneLue est une chaîne

// Sélection du nom et du chemin du fichier
NomCheminFichier ="\Mes Fichiers\Fichier.TXT"
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier)
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
BOUCLE
// Lecture de la première ligne du fichier
LigneLue = fLitLigne(IDFichier)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
SORTIR
FIN
// Fin de fichier ?
SI LigneLue = EOT ALORS SORTIR
// Traitement de la ligne lue
// Ici ajout à la fin d'un champ de saisie
SAI_ContenuFichier +=[RC]+ LigneLue
FIN
// Fermeture du fichier
fFerme(IDFichier)
ToastAffiche("Lecture du fichier terminée")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire