DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


Lit
  • Exemple 1 : Blocage d'un bloc d'octets dans un fichier externe
  • Exemple 2 : Blocage de la totalité d'un fichier externe
Exemple 1 : Blocage d'un bloc d'octets dans un fichier externe
Le code suivant permet de bloquer un bloc d'octets (50 octets) dans un fichier texte. Le fichier texte est ouvert en mode lecture/écriture. La portion bloquée sera accessible en lecture et en écriture uniquement par l'application qui bloque ce fichier.
// Déclaration et initialisation des variables
NomCheminFichier est une chaîne
IDFichier est un entier
ResBlocage est un booléen = Vrai
ResDéblocage est un booléen = Vrai
ResFermeFichier est un entier
 
// Sélection du nom et du chemin du fichier
NomCheminFichier = "C:\DOC\EXEMPLE.TXT"
 
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)
 
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Blocage d'un bloc de 50 octets
ResBlocage = fBloque(IDFichier, 0, 49)
// Affichage du message d'erreur si le blocage n'a pas été effectué
SI ResBlocage = Faux ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Traitements dans le bloc d'octets bloqué
...
// Fin des traitements dans le bloc d'octets bloqué
FIN
// Déblocage du bloc d'octets
ResDéblocage = fDébloque(IDFichier, 0, 49)
// Affichage du message d'erreur si le déblocage n'a pas été effectué
SI ResDéblocage = Faux ALORS Erreur(ErreurInfo(errMessage))
// Fermeture du fichier
ResFermeFichier = fFerme(IDFichier)
SI ResFermeFichier = -1 ALORS
// Affichage du message d'erreur si la fermeture n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
FIN
Exemple 2 : Blocage de la totalité d'un fichier externe
Le code suivant permet de bloquer la totalité d'un fichier texte. Le fichier est ouvert en mode lecture/écriture. Le fichier bloqué sera accessible en lecture et en écriture uniquement par l'application qui bloque ce fichier.
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
ResBlocage est un booléen
ResFermeFichier est un entier
 
// Sélection du nom et du chemin du fichier
NomCheminFichier = "C:\DOC\EXEMPLE.TXT"
 
// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)
 
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Blocage du fichier
ResBlocage = fBloque(IDFichier)
// Affichage du message d'erreur si le blocage n'a pas été effectué
SI ResBlocage = Faux ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Traitements dans le fichier bloqué
...
// Fin des traitements dans le fichier bloqué
FIN
// Fermeture du fichier
// La fermeture du fichier débloquera automatiquement le fichier
ResFermeFichier = fFerme(IDFichier)
SI ResFermeFichier= -1 ALORS
// Affichage du message d'erreur si la fermeture n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire