PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Fermeture d'un fichier externe
  • Fermeture d'un fichier externe (WINDEV Mobile)
Fermeture d'un fichier externe
WINDEVWEBDEV - Code ServeurEtats et RequêtesJavaPHPAjaxCode Utilisateur (MCU) Le code suivant permet de fermer un fichier externe. Le fichier est ouvert en mode lecture/écriture. Le fichier ouvert est librement accessible par les autres applications.
// Déclaration des variables
NomCheminFichier est une chaîne
IDFichier est un entier
ResFermeFichier est un entier

// Sélection du nom et du chemin du fichier
NomCheminFichier = "C:\MesRépertoires\Fichier.txt"

// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)

// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Traitements dans le fichier externe
...
// Fin des traitements dans le fichier externe
// Fermeture du fichier
ResFermeFichier = fFerme(IDFichier)
SI ResFermeFichier = -1 ALORS
// Affichage du message d'erreur si la fermeture n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
FIN
Fermeture d'un fichier externe (WINDEV Mobile)
Windows Mobile Le code suivant permet de fermer un fichier externe. Le fichier est ouvert en mode lecture/écriture. Le fichier ouvert est librement accessible par les autres applications.
// Déclaration des variables
NomCheminFichier est une chaîne = "\Mes Fichiers\Fichier.TXT"
IDFichier est un entier
ResFermeFichier est un entier

// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)

// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Traitements dans le fichier externe
...
// Fin des traitements dans le fichier externe // Fermeture du fichier
ResFermeFichier = fFerme(IDFichier)
SI ResFermeFichier = -1 ALORS
  // Affichage du message d'erreur si la fermeture n'a pas été effectuée
  Erreur(ErreurInfo(errMessage))
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire