PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Décompression d'un fichier (WINDEV)
  • Décompression d'un fichier (WEBDEV)
fDécompacte (Exemple)
Décompression d'un fichier (WINDEV)
WINDEVEtats et RequêtesCode Utilisateur (MCU) Le code suivant permet de décompresser un fichier. Le fichier à décompresser et le fichier décompressé sont sélectionnés avec la fonction fSélecteur. Une jauge permet d'indiquer le pourcentage de décompression. Cette jauge sera affichée dans la barre de message.
// -- Code de clic sur BTN_DécompresseFichier
// Code d'initialisation
NumEven est un entier
FichierADécompresser est une chaîne
FichierDécompressé est une chaîne
ResDécompression est un entier
 
// Sélection du fichier à décompresser
FichierADécompresser = fSélecteur("", "", "Sélection du fichier à décompresser",...
"Tous fichiers (*.*)" + TAB + "*.*", "", fselOuvre + fselExiste)
 
// Sélection du fichier décompressé
FichierDécompressé = fSélecteur("", "", "Sélection du fichier décompressé",...
"Tous fichiers (*.*)" + TAB + "*.*", "", fselCrée)
 
// Appel de l'événement pour afficher la jauge
NumEven = Evénement("JaugeDécompression", FenEnExécution(), jaugeCompactage)
 
// Décompression du fichier
ResDécompression = fDécompacte(FichierADécompresser, FichierDécompressé)
 
// Fin de l'événement
FinEvénement(NumEven)
 
// Affichage du message d'erreur si la décompression n'a pas été effectuée
SI ResDécompression <> 0 ALORS
  Erreur(ErreurInfo(errMessage))
SINON
  Info("Le fichier a été décompressé")
FIN
// Procédure locale JaugeDécompression
PROCÉDURE JaugeDécompression(wMessage, wParam, lParam)
SI wParam < 100 ALORS
  Jauge(wParam, 100)
  // Rafraîchissement de la fenêtre
  Multitâche(-1)
SINON
  // La décompression est finie
  Jauge()
FIN
Décompression d'un fichier (WEBDEV)
WEBDEV - Code ServeurAjax Le code suivant permet de décompresser un fichier.
// -- Code de clic sur BTN_DécompresseFichier
 
// Code d'initialisation
NumEven est un entier
FichierADécompresser est une chaîne
FichierDécompressé est une chaîne
ResDécompression est un entier
 
// Sélection du fichier à décompresser
FichierADécompresser = "C:\MesRépertoires\FichierCompressé.tx_"
// Sélection du fichier décompressé
FichierDécompressé = "C:\MesRépertoires\Fichier.txt"
 
// Décompression du fichier
ResDécompression = fDécompacte(FichierADécompresser, FichierDécompressé)
// Affichage du message d'erreur si la décompression n'a pas été effectuée
SI ResDécompression <> 0 ALORS
Erreur(ErreurInfo(errMessage))
SINON
Info("Le fichier a été décompressé")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire