PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Récupération des différentes dates d'un fichier
  • Exemple : Modification de la date de création d'un fichier
  • Exemple : Récupération des différentes dates d'un fichier (WINDEV Mobile)
  • Exemple 2 : Modification de la date de création d'un fichier (WINDEV Mobile)
Exemple : Récupération des différentes dates d'un fichier
WINDEVCode Utilisateur (MCU) Le code suivant permet de connaître les différentes dates d'un fichier.
// Déclaration des variables
ResDateCréation est une chaîne
ResDateModification est une chaîne
ResDateAccès est une chaîne
CheminFichier est une chaîne

// Sélection d'un fichier
CheminFichier = "C:\MesRépertoires\Fichier.txt"

// Récupération des différentes dates d'un fichier
ResDateCréation = fDate(CheminFichier, "", fCréation)
ResDateModification = fDate(CheminFichier, "", fModification)
ResDateAccès = fDate(CheminFichier, "", fAccès)
SI ResDateCréation <> "" ET ResDateModification <> "" ET ResDateAccès <> "" ALORS
// Affichage des différentes dates du fichier
Info("La date de création est : " + ResDateCréation + RC + ...
"La date de modification est : " + ResDateModification + RC + ...
"La date d'accès est : " + ResDateAccès)
SINON
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
Exemple : Modification de la date de création d'un fichier
WINDEVCode Utilisateur (MCU) Le code suivant permet de modifier la date de création d'un fichier par la date système de la machine.
// Déclaration des variables
ResDateCréation est une chaîne
ResDateSystème est une chaîne
CheminFichier est une chaîne

// Sélection d'un fichier
CheminFichier = "C:\MesRépertoires\Fichier.txt"

// Récupération de la date système sous forme AAAAMMJJ
ResDateSystème = DateSys()
// Modification de la date de création du fichier sélectionné
ResDateCréation = fDate(CheminFichier, ResDateSystème, fCréation)
SI ResDateCréation <> "" ALORS
        // Affichage de la date de création
        Info("La date de création est à présent : " + ResDateCréation)
SINON
       // Affichage du message d'erreur si la récupération n'a pas été effectuée
        Erreur(ErreurInfo(errMessage))
FIN
Exemple : Récupération des différentes dates d'un fichier (WINDEV Mobile)
Exemple 2 : Modification de la date de création d'un fichier (WINDEV Mobile)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire