DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Aide / WLangage / Fonctions WLangage / Fonctions standard / Fonctions de gestion des fichiers externes
fCompacte (Exemple)
WINDEVEtats et RequêtesCode Utilisateur (MCU) Compression d'un fichier (WINDEV)
Le code suivant permet de compresser un fichier. Le fichier à compresser et le fichier compressé sont sélectionnés avec la fonction fSélecteur. Une jauge permet d'indiquer le pourcentage de compression. Cette jauge sera affichée dans la barre de message.
// -- Code de clic sur BTN_CompresseFichier
 
// Code d'initialisation
NumEven est un entier
FichierACompresser est une chaîne
FichierCompressé est une chaîne
ResCompression est un entier
 
// Sélection du fichier à compresser
FichierACompresser = fSélecteur("", "", "Sélection du fichier à compresser", ...
"Tous fichiers (*.*)" + TAB + "*.*", "", fselOuvre + fselExiste)
 
// Sélection du fichier compressé
FichierCompressé = fSélecteur("", "", "Sélection du fichier compressé", ...
"Tous fichiers (*.*)" + TAB + "*.*", "", fselCrée)
 
// Appel de l'événement pour afficher la jauge
NumEven = Evénement("Aff_Jauge_Compression", FenEnExécution(), jaugeCompactage)
 
// Compression du fichier
ResCompression = fCompacte(FichierACompresser, FichierCompressé)
 
// Fin de l'événement
FinEvénement(NumEven)
 
// Affichage du message d'erreur si la compression n'a pas été effectuée
SI ResCompression <> 0 ALORS
Erreur(ErreurInfo(errMessage))
SINON
  Info("La compression a été effectuée")
FIN
// Procédure locale Aff_Jauge_Compression
PROCÉDURE Aff_Jauge_Compression(wMessage, wParam, lParam)
SI wParam < 100 ALORS
Jauge(wParam, 100)
  // Rafraîchissement de la fenêtre
  Multitâche(-1)
SINON
  // La compression est finie
  Jauge()
FIN
WEBDEV - Code ServeurAjax Compression d'un fichier (WEBDEV)
Le code suivant permet de compresser un fichier.
// -- Code de clic sur BTN_CompresseFichier
// Code d'initialisation
NumEven est un entier
FichierACompresser est une chaîne
FichierCompressé est une chaîne
ResCompression est un entier
 
// Sélection du fichier à compresser
FichierACompresser = "C:\MesRep\Compte.doc"
 
// Sélection du fichier compressé
FichierCompressé = "C:\MesRep\Compte.do_"
 
// Compression du fichier
ResCompression = fCompacte(FichierACompresser, FichierCompressé)
 
// Affichage du message d'erreur si la compression n'a pas été effectuée
SI ResCompression <> 0 ALORS
Erreur(ErreurInfo(errMessage))
SINON
Info("La compression a été effectuée")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire

Dernière modification : 24/08/2022

Signaler une erreur ou faire une suggestion | Aide en ligne locale