PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Transfert des données d'un fichier HFSQL vers un fichier texte
  • Exemple : Transfert du contenu d'une variable composée dans un fichier texte
Exemple : Transfert des données d'un fichier HFSQL vers un fichier texte
WINDEVWindowsLinuxJava Le code suivant permet d'écrire le contenu du fichier Client dans un fichier texte. Le fichier texte est ouvert en mode lecture/écriture.
// Déclaration et initialisation des variables
NomCheminFichier est une chaîne
IDFichier est un entier
TailleEcrit est un entier = 0
ResFermeFichier est un entier

// Sélection du nom et du chemin du fichier
NomCheminFichier = "C:\MesRépertoires\Fichier.txt"

// Ouverture du fichier
IDFichier = fOuvre(NomCheminFichier, foLectureEcriture)

// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Lecture du premier enregistrement
HLitPremier(Client, IDClient)
// Autres enregistrements à lire ? Erreur d'écriture ?
TANTQUE HEnDehors() = Faux ET TailleEcrit <> -1
// Écriture des données dans le fichier
TailleEcrit = fEcrit(IDFichier, ...
Client.NomClient + TAB + ...
Client.PrénomClient + TAB + Client.AgeRéel + RC)
// Lecture des enregistrements suivants
HLitSuivant(Client, IDClient)
FIN
// Affichage du message d'erreur si l'écriture n'a pas été effectuée
SI TailleEcrit = -1 ALORS Erreur(ErreurInfo(errMessage))
// Fermeture du fichier
ResFermeFichier = fFerme(IDFichier)
SI ResFermeFichier = -1 ALORS
// Affichage du message d'erreur si la fermeture n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
FIN
Exemple : Transfert du contenu d'une variable composée dans un fichier texte
WINDEV Le code suivant permet de récupérer la position et l'aspect d'une fenêtre à un instant donné. Ces informations sont stockées dans une variable composée (StructFenêtre). Le contenu de la variable composée est ensuite transféré (par son adresse) dans un fichier texte.
// Déclaration des variables
IDFichier est un entier
StructFenêtre est composée de
PosHorizontal, PosVertical sont des entiers
Largeur, Hauteur sont des entiers
FIN
ResEcriture est un entier
ResFermeFichier est un entier
 
// Création d'un fichier
IDFichier = fCrée("C:\Temp\FichierFenêtre.txt")
 
// Affichage du message d'erreur si la création n'a pas été effectuée
SI IDFichier = -1 ALORS
Erreur(ErreurInfo(errMessage))
SINON
// Récupération de la position et de l'aspect de la fenêtre
StructFenêtre.PosHorizontal = MaFenêtre.X
StructFenêtre.PosVertical = MaFenêtre.Y
StructFenêtre.Largeur = MaFenêtre.Largeur
StructFenêtre.Hauteur = MaFenêtre.Hauteur
// Écriture de la position et de l'aspect de la fenêtre dans le fichier texte
ResEcriture = fEcrit(IDFichier, &StructFenêtre, Dimension(StructFenêtre))
// Affichage du message d'erreur si l'écriture n'a pas été effectuée
SI ResEcriture = -1 ALORS Erreur(ErreurInfo(errMessage))
// Fermeture du fichier
ResFermeFichier = fFerme(IDFichier)
SI ResFermeFichier = -1 ALORS
// Affichage du message d'erreur si la fermeture n'a pas été effectuée
Erreur(ErreurInfo(errMessage))
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire