PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Exemple 1 : Récupération des attributs d'un fichier
fAttribut (Exemple)
Exemple 1 : Récupération des attributs d'un fichier
Le code suivant permet de connaître les attributs d'un fichier.
// Déclaration et initialisation des variables
ResAttribut est une chaîne
CheminFichier est une chaîne
AttFichier est une chaîne = "Le fichier est :"
// Attributs du fichier ?
ResAttribut = fAttribut(CheminFichier)
SI ResAttribut <> "ERR" ALORS
SI Position(ResAttribut, "A") ALORS AttFichier = AttFichier + RC + ...
TAB + "- un fichier archive"
SI Position(ResAttribut, "C") ALORS AttFichier = AttFichier + RC + ...
TAB + "- un fichier compressé"
SI Position(ResAttribut, "D") ALORS AttFichier = AttFichier + RC + ...
TAB + "- un répertoire"
SI Position(ResAttribut, "H") ALORS AttFichier = AttFichier + RC + ...
TAB + "- un fichier caché"
SI Position(ResAttribut, "R") ALORS AttFichier = AttFichier + RC + ...
TAB + "- un fichier en lecture seule"
SI Position(ResAttribut, "S") ALORS AttFichier = AttFichier + RC + ...
TAB + "- un fichier système"
// Affichage des attributs du fichier
Info(AttFichier)
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
WINDEVWEBDEV - Code ServeurEtats et RequêtesiPhone/iPadWidget IOSMac CatalystCode Utilisateur (MCU)Ajax
Exemple 2 : Modification des attributs d'un fichier
Le code suivant permet de modifier les attributs d'un fichier. Si ce fichier n'a pas l'attribut "lecture seule" (lettre R), le fichier devient automatiquement accessible en lecture (attribut "lecture seule", lettre R).
// Déclaration des variables
ResAttribut est une chaîne
ResAttributModif est une chaîne
CheminFichier est une chaîne
// Attributs du fichier sélectionné ?
ResAttribut = fAttribut(CheminFichier)
SI ResAttribut <> "ERR" ALORS
// Le fichier sélectionné est déjà en lecture seule ?
SI Position(ResAttribut, "R") <> 0 ALORS
Info("Le fichier est déjà en lecture seule")
SINON
ResAttribut = ResAttribut + "R"
// Modification des attributs du fichier
ResAttributModif = fAttribut(CheminFichier, ResAttribut)
SI ResAttributModif <> "ERR" ALORS
Info("Le fichier est à présent en lecture seule")
FIN
FIN
FIN
SI ResAttribut = "ERR" OU ResAttributModif = "ERR" ALORS
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire