PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


fCopieFichier (Exemple)
WINDEVEtats et RequêtesJava Copie d'un fichier
Le code suivant permet de copier un fichier. Le fichier à copier et le fichier copié sont sélectionnés avec la fonction fSélecteur. Une fenêtre de progression s'affiche (constante frJauge).
// Déclaration des variables
FichierACopier est une chaîne
FichierCopié est une chaîne
ResCopie est un booléen
 
// Sélection du fichier à copier
FichierACopier = fSélecteur("", "", "Sélection du fichier à copier", ...
"Tous fichiers (*.*)" + TAB + "*.*", "", fselOuvre + fselExiste)
 
// Sélection du fichier copié
FichierCopié = fSélecteur("", "", "Sélection du fichier copié", ...
"Tous fichiers (*.*)" + TAB + "*.*", "", fselCrée)
 
// Copie du fichier
ResCopie = fCopieFichier(FichierACopier, FichierCopié, frJauge)
// Affichage du message d'erreur si la copie n'a pas été effectuée
SI ResCopie = Faux ALORS
Erreur(ErreurInfo(errMessage))
SINON
Info("Le fichier a été copié")
FIN
WEBDEV - Code ServeurPHPAjax Copie d'un fichier (WEBDEV)
Le code suivant permet de copier un fichier.
// Déclaration des variables
FichierACopier est une chaîne
FichierCopié est une chaîne
ResCopie est un booléen
 
// Sélection du fichier à copier
FichierACopier = "C:\Répertoires\FichierB.doc"
// Sélection du fichier copié
FichierCopié = "C:\Répertoires\FichierA.doc"
 
// Copie du fichier
ResCopie = fCopieFichier(FichierACopier, FichierCopié)
// Affichage du message d'erreur si la copie n'a pas été effectuée
SI ResCopie = Faux ALORS
Erreur(ErreurInfo(errMessage))
SINON
Info("Le fichier a été copié")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire