PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Remplir une table hiérarchique avec l'arborescence des dossiers d'une base Outlook
EmailChangeDossier (Exemple)
Remplir une table hiérarchique avec l'arborescence des dossiers d'une base Outlook
Le code suivant permet de remplir une table hiérarchique avec l'ensemble des dossiers présents dans une base Outlook.
// Déclaration des variables
//---------------------------
// Identifiant de la session
IDSession est un entier
// Liste des dossiers
ListeDossier est une chaîne
// Nom de chaque dossier
NomDossier est une chaîne
// Indice de chaque dossier
IndiceDossier est un entier = 1
// Début du nom de chaque dossier
Partie1Dossier est une chaîne
// Fin du nom de chaque dossier
Partie2Dossier est une chaîne
// Nombre d'emails présents dans chaque dossier
NbEmail est un entier
// Ouverture de la session
IDSession = OutlookOuvreSession("")
// Erreur rencontrée ?
SI IDSession = 0 ALORS
Erreur("Erreur lors de l'ouverture de la session", ErreurInfo())
SINON
// Liste des dossiers
ListeDossier = EmailListeDossier(IDSession, LstDossierTous)
// Extraction du 1° dossier listé
NomDossier = ExtraitChaîne(ListeDossier, IndiceDossier, RC)
// Manipulation des dossiers
TANTQUE NomDossier <> EOT
// Changement du dossier en cours
EmailChangeDossier(IDSession, NomDossier)
// Nombre d'emails dans le dossier en cours
NbEmail = EmailNbMessage(IDSession)
// Extraction des différentes parties du nom du dossier
Partie2Dossier = ExtraitChaîne(NomDossier, 1, "\", DepuisFin)
Partie1Dossier = ExtraitChaîne(NomDossier, 1, "\" + ...
Partie2Dossier)
// 1° dossier à ajouter dans la table ?
SI IndiceDossier = 1 ALORS
TableAjouteFils(TABLEH_TableDossier, Null, ...
Partie2Dossier, NbEmail, NomDossier)
SINON
// Remplacement des "\" par des TAB
// dans le début du nom du dossier
Partie1Dossier = Remplace(Partie1Dossier, "\", TAB)
// Ajout des dossiers suivants
TableAjouteFils(TABLEH_TableDossier, Partie1Dossier, ...
Partie2Dossier, NbEmail, NomDossier)
FIN
// Incrémentation de l'indice du dossier
IndiceDossier ++
// Extraction des autres dossiers listés
NomDossier = ExtraitChaîne(ListeDossier, IndiceDossier, RC)
FIN
FIN
 
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire